Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > Regional Forums > UK
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 04-13-2020, 08:32 AM   #1
Dupont
 
Drives: Yaris 56 semi auto
Join Date: Apr 2019
Location: Brum
Posts: 2
Yaris MMT Transmission

Hello, I have a 2006 Yaris with MMT gearbox. It has 36,000 miles on it and runs really well and in excellent condition.

However, it has developed an annoying fault that occurs once in a while. I put car in neutral and start engine as normal then wait a second or two before putting it into E to move forward, but instead of that happening I hear a loud clang from engine/gearbox area and then the N starts flashing and I cannot select any gears. Also a red light is displayed on dash like a star shape.

If I do nothing and wait a few hours then the car starts fine and gears can be selected or if I disconnect battery and wait ten minutes before reconnecting it starts up fine. The red light has gone and gears are selected fine.

Any ideas as I am at a loss?

Thanks in advance.
Dupont is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Toyota Yaris Transmission (5 speed manual) Viperoni Items for Sale by private party 55 01-07-2016 11:37 AM
Problem help MickZEL DIY / Maintenance / Service 38 08-01-2011 03:52 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 09:53 PM
Yaris Transmission? jmew0ng General Yaris / Vitz Discussion 1 08-04-2006 12:25 PM


All times are GMT -4. The time now is 06:10 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.