Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 10-15-2020, 10:37 PM   #1
Chip Whitley
 
Drives: 2007 Auto Hatchback
Join Date: Jan 2017
Location: Locust Grove, VA
Posts: 7
Getting a P0171 code even after taking it to the shop

So about two weeks ago my 07 Yaris Hatchback's check engine light came on throwing code P0171 (System Too Lean - Bank 1). I made an appointment for a diagnosis with a local shop that has a good reputation. My MAF sensor is three months old so they said that wasn't the problem and then recommended a smoke test to find any leaks. They couldn't find a single leak so then recommended I replace both O2 sensors. I also had a new muffler installed which is unrelated to the code, but it was time for a replacement as my old one was getting crazy loud. Anyway, I left my car with them Monday and picked it up yesterday.

To be honest, it runs better now then it did when I bought it a few years ago. Much quieter with a bit more pep although it's still slow as hell since it's a Yaris. I thought everything was fine, but the check engine light came back on with the same code on my way home from work today. I called the shop back and made an appointment for Monday morning. I'll leave it there for the day as I have to work. Also, the mechanic mentioned something to me about using a bottle of sea foam fuel injector cleaner before I ended up agreeing to the new O2 sensors. Should I try that before I take it back in Monday? Any idea what else it could be? I'm $750 poorer now because of this issue so any advice would be greatly appreciated.
Chip Whitley is offline   Reply With Quote
Old 10-16-2020, 12:34 AM   #2
komichal
 
Drives: Yaris 2007 1.3 2SZFE 64kW
Join Date: May 2012
Location: CZ
Posts: 204
Personally I do not think O2 sensor will help. There are other codes indicating O2 sensor issues. On the other hand - a friend of mine had P0171 as well and it stopped popping in after he changed battery. Do not ask me why... So everything is possible.

Are you sure the new MAF is seated properly? Some rogue air can go around and compromise the measurement.

I would also clean the throttle body and disconnect the battery for a few minutes so that the ECU can re-learn from scratch the air intake values, position the TB flap correctly etc.
komichal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OFFICIAL Yaris SEDAN thread SimmZ Photo-Video-Media Gallery 1706 01-13-2020 11:20 AM
The Official "Bamboo the Yarisworld Traveler" Thread (v4, part 2) Darb Off-topic / Other Cars / Everything else Discussions 86 10-18-2017 08:03 AM
DIY Gauge dj92 Fuel Economy Forum 11 12-06-2013 10:03 PM
Sponsors List RogueYaris Sponsors Classifieds Area 14 01-05-2013 10:23 PM
Anybody know the code? Driver New YARIS Purchase Forum 5 08-20-2006 06:56 PM


All times are GMT -4. The time now is 08:53 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.