Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > General Yaris / Vitz Discussion
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 09-13-2021, 04:16 PM   #1
mjl1297
 
Drives: 2008 Yaris
Join Date: Sep 2012
Location: Tennessee
Posts: 21
Windshield wiper issue...

My wife has a 2008 Yaris and today she said she turned the windshield wipers on, they worked, and then she turned them off. When she tried to turn them on again the wipers didnít move.

So she went and did her shopping, drove home, and then turned the wipers on and off again only to have the same scenario repeat.

Any idea as to what may be going on and what I can check myself? Many thanks.
mjl1297 is offline   Reply With Quote
Old 09-13-2021, 04:56 PM   #2
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,340
Figure out which fuse controls the windshield wipers and see if it’s good. If it’s not and you put a new one in end it blows, you better take it to a shop.

If the car is without windshield wipers, you can use rain off until you get it fixed. It might be a good idea to use it now in case they don’t work. Even if the rain won’t blow off at low speed, you can still see because it beats up.

Good luck and tell us what happens!
__________________
Synthetic Oil: Its All In Your Head
bronsin is online now   Reply With Quote
Old 09-13-2021, 04:57 PM   #3
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,340
Maybe it’s a loose connector?
__________________
Synthetic Oil: Its All In Your Head
bronsin is online now   Reply With Quote
Old 09-14-2021, 08:18 AM   #4
mjl1297
 
Drives: 2008 Yaris
Join Date: Sep 2012
Location: Tennessee
Posts: 21
Thanks for the reply bronsin.

It might be a loose connection. I won't be able to check it until Friday at the earliest. When I got home late last night they did nothing when I switched them on not even a sound of the motor buzzing or anything.
mjl1297 is offline   Reply With Quote
Old 09-14-2021, 09:27 AM   #5
CrankyOldMan
2ZR swap. DO IT! Ask how!
 
CrankyOldMan's Avatar
 
Drives: 09 Meteoric Metallic HB
Join Date: Feb 2011
Location: West Michigan
Posts: 2,321
Have you checked all of the speeds/positions on the stalk? That might help narrow it down to the switch, motor or wire harness.

Good call on the motor sounds. It's unlikely that the arms would be stripped on the shafts but that would be one possible cause.

If it was the fuse it would be an all-or-nothing issue. Intermittent operation sounds like a bad connection somewhere or the motor itself is going out.
CrankyOldMan is offline   Reply With Quote
Old 09-14-2021, 09:58 AM   #6
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,340
Quote:
Originally Posted by mjl1297 View Post
Thanks for the reply bronsin.

It might be a loose connection. I won't be able to check it until Friday at the earliest. When I got home late last night they did nothing when I switched them on not even a sound of the motor buzzing or anything.
Remember rain X is your friend!
__________________
Synthetic Oil: Its All In Your Head
bronsin is online now   Reply With Quote
Old 09-14-2021, 10:48 AM   #7
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,340
On my smart TV I did a YouTube search for troubleshooting windshield wiper. I will post the link but I have Parkinson’s and it’s difficult using my iPad. But if you do a YouTube search you could watch The same videos. I have to believe that would solve your problem!
__________________
Synthetic Oil: Its All In Your Head
bronsin is online now   Reply With Quote
Old 09-15-2021, 11:51 PM   #8
mjl1297
 
Drives: 2008 Yaris
Join Date: Sep 2012
Location: Tennessee
Posts: 21
Thanks guys for the helpful responses. I'll have some time during my upcoming vacation to check the problem out!

Thanks for the YouTube video suggestion bronsin. I definitely believe the mechanism is seizing. They came on briefly the other night but were moving with a slow. stuttering motion and eventually stopped altogether.

Will post back with an update when I get a chance to diagnose and hopefully resolve the issue.
mjl1297 is offline   Reply With Quote
Old 09-16-2021, 05:06 AM   #9
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,340
If you can get at the motor give it a few good wacks. Also the motor may be ok but one of the joints seized.
__________________
Synthetic Oil: Its All In Your Head
bronsin is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Yaris Windshield wiper switch WalterWhite61 General Yaris / Vitz Discussion 0 06-30-2019 08:20 PM
Wiper Sync Issue GED9000 DIY / Maintenance / Service 1 01-26-2016 03:49 PM
Hose for windshield wiper broke HDS DIY / Maintenance / Service 1 04-06-2012 10:26 AM
Passenger side windshield wiper daf62757 General Yaris / Vitz Discussion 1 12-23-2011 05:12 PM
windshield wiper issue whiteghetto DIY / Maintenance / Service 7 02-15-2009 05:22 PM


All times are GMT -4. The time now is 03:12 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.