Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > Forced Induction Forum
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 05-14-2010, 07:55 PM   #1
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
trd turbo tunning plan

hi everybody i am from Costa Rica, I have a Yaris Tsport 2004 , and i was planing to turbo my car for at least from year and a half ago, the first option was the scion xb kit from greddy but since it would requiere some piping adjustment, i start seaching for other options, i found a forum called zero to hundred an to my surprise a guy from malasya was selling an original turbo half cut from a vitz rs turbo , with the trd turbo on it.
so i asked the guy if he could sell me just the parts that i need to run the turbo, on my engine, after some talking he was able to tear down the engine and sell me everything i need, so i was very happy, he send everything by UPS, so was very quick.
I never meet him before i just send the money, but it was a clean transaction.
so check the pictures, maybe in a week i will install everything.
Attached Images
File Type: jpg CIMG2375.jpg (141.4 KB, 593 views)
File Type: jpg CIMG2377.jpg (127.7 KB, 569 views)
File Type: jpg CIMG2388.jpg (113.5 KB, 562 views)
File Type: jpg CIMG2391.jpg (119.9 KB, 562 views)
File Type: jpg CIMG2398.jpg (116.0 KB, 553 views)
File Type: jpg CIMG2400.jpg (99.6 KB, 548 views)
File Type: jpg CIMG2399.jpg (115.3 KB, 540 views)
File Type: jpg CIMG2431.jpg (148.2 KB, 538 views)
File Type: jpg CIMG2435.jpg (149.1 KB, 543 views)
File Type: jpg CIMG2383.jpg (93.9 KB, 540 views)
fett22 is offline   Reply With Quote
Old 05-14-2010, 08:18 PM   #2
Yoda
 
Yoda's Avatar
 
Drives: 2008 Black Sedan
Join Date: Oct 2008
Location: FL
Posts: 966
you lucky dog
Yoda is offline   Reply With Quote
Old 05-15-2010, 08:28 AM   #3
Parmas
 
Parmas's Avatar
 
Drives: Vitz RS Turbo
Join Date: Nov 2008
Location: ML
Posts: 575
Nice you should do some good power with this kit!

How much you bought it anyway?

I think those injectors are used on standard 1ZZ engines
Parmas is offline   Reply With Quote
Old 05-15-2010, 09:30 AM   #4
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
2700$ kit, shipping 1000$. total 3700,expensive yes , but original trd plan.
by the way, did someone has a diagrams for these kit, i just found one image.
but need more instructions.
Thanks.
Attached Images
File Type: jpg diagramaturboparteszp5.jpg (82.0 KB, 509 views)
fett22 is offline   Reply With Quote
Old 05-18-2010, 06:22 PM   #5
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
Today we conect the computer ,we tought were going to have some trouble with the car inmobbilizer system, but thanks god, everything went fine, car engine start with no problems.
after that, the mechanic start tear down all the stock parts, i hope by the end of the wekend the car will have everything installed so we could do some tunning.
will post some pics tomorrow.
Can wait to get everything installed.
fett22 is offline   Reply With Quote
Old 05-18-2010, 09:02 PM   #6
Black Yaris
der Zeck
 
Black Yaris's Avatar
 
Drives: '05 Audi A4 1.8t quattro
Join Date: Sep 2006
Location: Toledo, OH
Posts: 5,268
nice build thread
__________________
Black Yaris is offline   Reply With Quote
Old 05-18-2010, 09:39 PM   #7
marcus
toyota
 
marcus's Avatar
 
Drives: 2007 Yaris RS Blazed
Join Date: Oct 2006
Location: toronto, canada
Posts: 3,666
sick....
marcus is offline   Reply With Quote
Old 05-18-2010, 11:23 PM   #8
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
By the way ,the time my yaris whats doing the 1/4 mile was 16.4 seconds, we will see whats going to be the time now with the turbo, here are the specs for the Trd tunning plan, i now its not 300whp, but 150 its good for now.

specs:

"The RS turbo Vitz has an ecu calibrated for the larger injectors that feed
150 ps at the flywheel which in turn is 127 ps at the wheels"

110kW(150PS)/6,400rpm 110kW (150 CV) / 6.400 rpm
196N・m(20.0kg・m)/4,800rpm 196N • m (20.0kg • m) / 4,800 rpm

other info:
TOYOTA DENSO 23250- 22030 / 2zzge injectors .
ihi turbo Rhf4 17201-yw602
fett22 is offline   Reply With Quote
Old 05-18-2010, 11:30 PM   #9
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
a pic of my yaris
Attached Images
File Type: jpg CIMG2218.jpg (121.7 KB, 471 views)

Last edited by fett22; 05-19-2010 at 09:53 PM.
fett22 is offline   Reply With Quote
Old 05-19-2010, 07:26 PM   #10
PETERPOOP
 
PETERPOOP's Avatar
 
Drives: 08 white liftback
Join Date: Oct 2008
Location: Oahu
Posts: 3,689
you going to run a turbo back exhaust setup now? 2.25"?
PETERPOOP is offline   Reply With Quote
Old 05-19-2010, 07:47 PM   #11
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
Quote:
Originally Posted by PETERPOOP View Post
you going to run a turbo back exhaust setup now? 2.25"?
haha ,i already have 2.25 exhaust piping, but probably what i would need its a new clucht, but for now were gonna go with stock one.
havent go to garage jet, tomorrow ill get some pics.
talk to mechanic today and he said car would be ready for friday EOB.
fett22 is offline   Reply With Quote
Old 05-26-2010, 03:45 PM   #12
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
Intake gave us a problem air is getting away from some hose , also a conecctor of the oil cooler didnt fit, so because of that one week with nothing, car engine is working but cant mantain minimum, oil cooler screw cant find one that fits. so pretty piss rigth now.
fett22 is offline   Reply With Quote
Old 05-27-2010, 03:45 AM   #13
rector
 
rector's Avatar
 
Drives: vitz turbo
Join Date: Mar 2010
Location: under the bonnet
Posts: 8
[quote=fett22;475018]Intake gave us a problem air is getting away from some hose , also a conecctor of the oil cooler didnt fit, so because of that one week with nothing, car engine is working but cant mantain minimum, oil cooler screw cant find one that fits. so pretty piss rigth now.[/QUO

hello everybody!my first post to this fantastic forum and i hope that this post will help fett22.

just check if any of these two parts are missing!that sould solve the problem.hope that helps.

rector is offline   Reply With Quote
Old 05-27-2010, 08:35 PM   #14
advocate
 
Drives: car
Join Date: Oct 2008
Location: location
Posts: 1,040
this a stage 0 kit?
advocate is offline   Reply With Quote
Old 05-28-2010, 12:41 AM   #15
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
[quote=rector;475168]
Quote:
Originally Posted by fett22 View Post
Intake gave us a problem air is getting away from some hose , also a conecctor of the oil cooler didnt fit, so because of that one week with nothing, car engine is working but cant mantain minimum, oil cooler screw cant find one that fits. so pretty piss rigth now.[/QUO

hello everybody!my first post to this fantastic forum and i hope that this post will help fett22.

just check if any of these two parts are missing!that sould solve the problem.hope that helps.

thanks for the info thats was exactly the piece i need the one with number 1 , we get it ,and and car is ready now, hahaha so happy right now , couple of years until these moment, i drive the car today and was fantastic felt my heart pumping so fast,ha ha.
also the other problem we where getting was with the custom air intake, seems the MAF doesnt go well with the air intake , so we use the stock air filter box and everything went excelent, didt get any CEL, will post pics tomorrow.
cant wait until monday to go to track, to check time.

thanks to all for all the info.
fett22 is offline   Reply With Quote
Old 05-28-2010, 01:08 AM   #16
PETERPOOP
 
PETERPOOP's Avatar
 
Drives: 08 white liftback
Join Date: Oct 2008
Location: Oahu
Posts: 3,689
sweet
PETERPOOP is offline   Reply With Quote
Old 06-06-2010, 07:58 PM   #17
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
after adding and old blow off valve , i am getting a air leak and CEL, what is weirds is at the same time I get CEL, i also got TRC AND VSC lights, have to wait until i get a new blow off to see if that fix the problem.
Does anybody here have something similar to this issue.
its Definitely de blow off couse if i put the palm of my hand it suck it,when its supposed to be closed.
And the CEL started immediately after i install the blow off.
thanks.
fett22 is offline   Reply With Quote
Old 06-08-2010, 09:59 AM   #18
fett22
 
Drives: 2004 yaris t-sport turbo
Join Date: Aug 2009
Location: Costa Rica
Posts: 21
Seems like the person who weld the flanger never take out the BOV, so he fry the base rubber seal, an the air was leaking from it, today i will replace the seal with a new one.

Too many post an no pics, i will post some today , just cant find my camera cable.
fett22 is offline   Reply With Quote
Reply

Tags
trd turbo plan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trd sport M badge (carbon RARE), td05 Mitubishi turbo flatline16 Items for Sale by private party 14 09-28-2010 07:20 PM
TRD Turbo Vitz 田中秀樹 Forced Induction Forum 26 09-26-2007 03:07 PM
Yaris Sport Turbo BY TRD Fer.pa Central and South America 18 07-31-2007 12:05 AM
TRD Turbo ECHo Hatch - Yaris TS CASTREX General Yaris / Vitz Discussion 12 04-03-2007 11:04 AM
NCP 91 RS 1500 TRD Turbo ????? ramishrrr General Yaris / Vitz Discussion 3 01-15-2007 05:51 PM


All times are GMT -4. The time now is 03:48 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.